18 lines
458 B
Diff
18 lines
458 B
Diff
diff --git a/fs/cpio/cpio.mk b/fs/cpio/cpio.mk
|
|
index 28a435dd5e..81f8c393d1 100644
|
|
--- a/fs/cpio/cpio.mk
|
|
+++ b/fs/cpio/cpio.mk
|
|
@@ -37,7 +37,11 @@ ROOTFS_CPIO_OPTS += --reproducible
|
|
endif
|
|
|
|
define ROOTFS_CPIO_CMD
|
|
- cd $(TARGET_DIR) && find . | cpio $(ROOTFS_CPIO_OPTS) --quiet -o -H newc > $@
|
|
+ cd $(TARGET_DIR) && \
|
|
+ find . \
|
|
+ | LC_ALL=C sort \
|
|
+ | cpio $(ROOTFS_CPIO_OPTS) --quiet -o -H newc \
|
|
+ > $@
|
|
endef
|
|
|
|
ifeq ($(BR2_TARGET_ROOTFS_CPIO_UIMAGE),y)
|